Tag Archive: resource pool



I was creating a new Xenserver test pool.  A simple thrasher setup that would have two hosts.  I created the pool and when I tried to add the second server; I received an error message:

This server has a different Active Directory configuration to the master

Odd message what has AD have to do with anything? Then….I remembered this was a temporary setup and was added to AD at one point.

I removed it by clicking the “Leave Domain” button found under the Users tab.

It didn’t need a reboot and was added to the new pool.

Advertisements

One thing I have noticed on the Net; information about Citrix can be lacking at times.

I had an instance where a resource pool was established and the thinking behind it was wrong. I wanted to destroy it. I started Xencenter and accessed the doomed pool. I removed all the extra Xenserver hosts by simply right-clicking the entry and selecting “Remove Server from pool”

When it came time to kill the master, there wasn’t an option. I tried the xe options of eject and forgetting but they gave errors.

As mentioned, the Net was lacking on information. So I basically started hunting around thinking “it can’t be a reload!” I didn’t want to go through patching again.

I looked at the Xencenter window tab for Pool and sure enough there was an interesting entry!

Make into standalone server

I selected the master host, clicked “Pool” and selected the option. It ran really fast and the pool entry disappeared with the server showing up at the bottom of list of resources. I expected it to reboot but it didn’t. I gave it a reboot for good measure and then added the ex-master as a host to the correct pool.